证券配资在线平台 十天内首次出现涨停选股公式(附源码破译和源码)

发布日期:2024-07-06 03:28    点击次数:109

编程思路破译证券配资在线平台

主板首涨停赋值:(收盘价=计算涨停价 AND (沪深京品种类型=2) OR 沪深京品种类型=1))

   统计10日中满足主板首涨停的天数=1 AND 主板首涨停

N赋值:40

B1赋值:上次1日前的收盘价的5日简单移动平均上穿收盘价的10日简单移动平均距今天数

B2赋值:(B1+1日内收盘价的最高值/B1+1日前的收盘价-1)*100

B3赋值:收盘价的5日简单移动平均上穿收盘价的10日简单移动平均

B4赋值:10日内成交量(手)的最低值=30日内成交量(手)的最低值 AND 最近30日存在成交量(手)的5日简单移动平均>成交量(手)的10日简单移动平均ANDMA(成交量(手),10)>成交量(手)的20日简单移动平均

B5赋值:收盘价/B1+1日前的收盘价>1.05

RSV赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100

K赋值:RSV的3日[1日权重]移动平均

D赋值:K的3日[1日权重]移动平均

J赋值:3*K-2*D

B赋值:K上穿D

   B2>10 AND B2<N AND B3ANDB4 AND B5 AND 收盘价的5日简单移动平均>收盘价的60日简单移动平均 AND B

A1赋值:开盘价<1日前的收盘价

A2赋值:收盘价/1日前的收盘价<1.03

A3赋值:收盘价的30日简单移动平均/1日前的收盘价的30日简单移动平均>1.005

A4赋值:(收盘价/收盘价的30日简单移动平均)位于1和1.05之间

A5赋值:成交量(手)/1日前的成交量(手)<0.8

输出   抓牛:A1 AND A2 AND A3 AND A4 AND A5

程序源码

   主板首涨停:=(C=ZTPRICE(REF(CLOSE,1),0.1) AND (FINANCE(3)=2) OR FINANCE(3)=1));

   COUNT(主板首涨停,10)=1 AND 主板首涨停;

   N:=40;

   B1:=BARSLAST(REF(CROSS(MA(C,5),MA(C,10)),1));

   B2:=(HHV(C,B1+1)/REF(C,B1+1)-1)*100;

   B3:=CROSS(MA(C,5),MA(C,10));

   B4:=LLV(V,10)=LLV(V,30) AND EXIST(MA(V,5)>MA(V,10) AND MA(V,10)>MA(V,20),30);

   B5:=C/REF(C,B1+1)>1.05;

   RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

   K:=SMA(RSV,3,1);D:=SMA(K,3,1);

   J:=3*K-2*D;B:=CROSS(K,D);

   B2>10 AND B2<N AND B3ANDB4 AND B5 AND MA(C,5)>MA(C,60) AND B;

   A1:=OPEN<REF(CLOSE,1);

   A2:=CLOSE/REF(CLOSE,1)<1.03;

   A3:=MA(CLOSE,30)/REF(MA(CLOSE,30),1)>1.005;

   A4:=BETWEEN((CLOSE/MA(CLOSE,30)),1,1.05);

   A5:=VOL/REF(VOL,1)<0.8;

   抓牛:A1 AND A2 AND A3 AND A4 AND A5;

该公式包含未来函数:FINANCE

注:

       馆内各种公式为学习编程而保存,实战使用前一定要看其中是否有未来函数并自己亲自测试成功率,决不能依据公式名称的描述和形容去投资,据此入市造成投资损失由投资者自己承担。

       发文不易证券配资在线平台,如获益,欢迎赞赏,赞赏必复!

本站仅提供存储服务,所有内容均由用户发布,如发现有害或侵权内容,请点击举报。